Team documents are not displaying properly

Incident Report for signNow

Resolved

This incident has been resolved.
Posted May 06, 2026 - 20:18 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 06, 2026 - 17:46 EDT

Investigating

We’ve identified an issue where team documents are not displaying properly for some users. Our team is currently investigating the root cause and working toward a resolution.
Posted May 06, 2026 - 17:03 EDT
This incident affected: Web.