Issue with sending SMS invites

Incident Report for signNow

Resolved

The reported issue has been successfully resolved. All systems are functioning normally.
Posted Mar 11, 2026 - 17:10 EDT

Investigating

We are currently investigating the issue.
Posted Mar 11, 2026 - 12:02 EDT
This incident affected: Web.